adam:GO Cellular Issues

I have heard from some that with service being bad in some areas, they try to use wifi calling, but with the adam:GO setup it seems to prefer cellular, even if service is really bad.

In my experience, LTE is fast, but limited. We had issues with service, so we switched our phones to 3G. This helped a great deal.

It is under Cellular>Cellular Data Options>Voice and Data.

Switch that to 3G and you should notice much better service.

1 Like

Thanks for the tip @Victor as I myself have gotten into the habit of simply going to Airplane Mode at places I frequent that have good WiFi.