Random MAC troubles

I’m running into problem with tons of devices showing on the dashboard because of the random Mac. It is causing problems becasue other devices that have been entered get mixed up with the IP addresses and switch policies. I’ve tried deleting all devices in my default guest policy, but it’s still showing as a different device. The Mac is the same, but the up is different, and when going to mytools, it will appear in another policy instead of the one it’s supposed to be in.

The problem might be on the end user if they are using a wifi devices. Most of the mobile devices will connect to wifi with a random mac address.

On an android, you will need to go to settings, connections, wifi, select current wifi, advance and under MAC address type, select use phone mac.