Not blocking sites (Starlink - Whitelist)


I followed the setup guide which successfully created all the necessary rules for my adamone. I’m using a pfSense Netgate 2100. The rules are as follows:

The pfsense is connected to our router which is getting its internet from a Starlink connection. Would this affect the adamone firewall in anyway? For some reason the whitelist I created is not working, the sites which are not on the list are still accessible. Would someone be able to assist with fixing this? I’m new to this so it’s been a huge learning curve.

Hey welcome to the forum @Murray_Zilke
When you ran the adamone-setup configure command were there any warnings shown at the end of the setup?

Hi atw,

Thank you.

No warnings came up after the installation

I was playing around with pfsense and adamone trying to figure it out. I reinstalled it a few minutes ago and this is the installation wrap up:

OK it looks like your problem is that Services / DNS Resolver is still enabled. Please try disabling it and then run the adamone-setup command again.

Okay, I did as you instructed and disabled the DNS Resolver and redid the adamone setup. However it still doesn’t work.

Is your computer set to use your router for DNS? This normally happens via DHCP automatically.
What happens when you run the command dig from a shell on your computer?

If you’d like you can also generate a support file on pfSense by running the command adamone-issue and then email it to or DM it to me.

When you guys resolve this, would you be willing to post the fix here? I’m learning as I go and have never gotten pfsense to work right and would really like to see a good setup with Adam:One


Have you guys tried watching @David’s how-to video? Perhaps it will help, here’s the link: